Citibank customers unable to connect accounts or update bank feeds in QuickBooks
Incident Report for QuickBooks
Resolved
An earlier issue with Citibank connection is working again. We apologize for the interruption in service and thank you for your patience as we worked with Citi on resolution.
Posted Feb 16, 2019 - 08:00 PST
Investigating
Some Citibank customers are currently unable to connect accounts or refresh accounts in bank feeds to download transactions. This is impacting QuickBooks Online and QuickBooks Self-Employed. We are working with Citi on fixing the problem. We apologize for the inconvenience and hope to get everything up and running soon.
Posted Feb 15, 2019 - 10:07 PST