Latency Issues with QuickBooks
Incident Report for QuickBooks
Resolved
This incident has now been resolved
Posted Oct 07, 2021 - 03:28 PDT
Monitoring
A fix has been implemented and we are now seeing successful logins into QuickBooks. Please try accessing QuickBooks now.
Posted Oct 07, 2021 - 03:09 PDT
Investigating
We are aware that some customers are unable to access QuickBooks Online. We are working to resolve this as quickly as possible.
Posted Oct 07, 2021 - 02:24 PDT
This incident affected: QuickBooks Online (United Kingdom).