QuickBooks Desktop Payroll is experiencing an outage
Incident Report for QuickBooks
Resolved
This incident has been resolved.
Posted Feb 09, 2021 - 08:50 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2021 - 08:40 PST
Investigating
We are currently experiencing a system issue that may impact your ability to send payroll. We are working to restore your service as quickly as possible. Please subscribe to this page for updates, or check back later. We will update this issue as soon as we have more information.
Posted Feb 09, 2021 - 08:10 PST
This incident affected: QuickBooks Desktop.