Some customers are unable to update credit card payment details on their QuickBooks Online account
Incident Report for QuickBooks
Resolved
We are pleased to share that a fix has been implemented to resolve the payment failure error. Please make another attempt to update credit card details on your QuickBooks Online account. Thank you for your patience as we worked to resolve this.
Posted Dec 01, 2021 - 18:19 PST
Investigating
We are aware that some customers are unable to update credit card payment details on their QuickBooks Online account, getting error 81623 or 81822. Engineering team is investigating this issue and working on a solution. We apologise for any inconvenience caused.
Posted Dec 01, 2021 - 17:40 PST
This incident affected: QuickBooks Online (Australia).