Quickbooks Online Latency Issue

Incident Report for QuickBooks

Resolved

Earlier today, some users experienced issues with QuickBooks Online (QBO) features. Our teams have identified and resolved the underlying problem. All services are now restored and functioning normally.

We appreciate your understanding and patience.
Posted Aug 19, 2026 - 09:54 PDT

Monitoring

The latency issue with QuickBooks has been resolved. Engineering Team have implemented a fix and continue to monitor for full recovery
Posted Aug 19, 2026 - 09:13 PDT

Investigating

We are aware that some customers are experiencing latency when using QuickBooks Online. Our engineering team is actively investigating the issue to identify the root cause and restore normal performance as quickly as possible.
We appreciate your patience and will provide further updates as more information becomes available.
Posted Aug 19, 2026 - 07:30 PDT
This incident affected: QuickBooks Online (United States, EMEA, Canada).