Some QuickBooks Online customers are unable to login
Incident Report for QuickBooks
Resolved
We're happy to report that this issue has been resolved. Users are reporting they now can successfully log in to QuickBooks Online.

We appreciate your patience. Thank you for using QuickBooks Online.
Posted May 29, 2024 - 13:03 PDT
Update
We are continuing to monitor for any further issues.
Posted May 29, 2024 - 12:59 PDT
Monitoring
Our team continues to investigate what may be causing the login issue. Some customers have since reported that they've been able to successfully login to QuickBooks Online at this time.

If you are still unable to login, we would advise you to attempt logging in via another WiFi network if possible. We appreciate your patience.
Posted May 29, 2024 - 12:24 PDT
Identified
We are receiving some reports that some QuickBooks Online users are unable to log in to their companies. They are instead seeing the error message "Something's not right, try again later. If the problem continues, contact us."

Many of these users are using the ISP Starlink to attempt to log in to their companies. Users have been instructed to try a different ISP if possible.

Our team is actively working to identify root cause and hopes to have the issue resolved as soon as possible.
Posted May 29, 2024 - 10:33 PDT
This incident affected: QuickBooks Online (United States, Canada).