QuickBooks Payroll and Veteran's Day
Incident Report for QuickBooks
Resolved
All payroll that was delayed due to the banking holidays should now be deposited into your employees accounts.
Posted Nov 16, 2021 - 06:35 PST
Monitoring
Due to the bank holiday, Veteran's Day, direct deposit payroll submitted after 5 pm, Wednesday, Nov. 10th, is being processed Friday, Nov 12th, the next business day. Employees of same-day direct deposit customers should be paid by close of business Friday, Nov. 12th. Employees of next-day direct deposit customers should be paid by close of business Monday, Nov. 15th.
Posted Nov 12, 2021 - 08:43 PST
Identified
Due to Veteran's day - a bank holiday - all payroll posted after 5pm on Wednesday will be processed today and there will be a one day delay.
Posted Nov 12, 2021 - 06:59 PST
This incident affected: QuickBooks Online (United States).