QuickBooks Online is currently experiencing an email outage linked to Gmail accounts
Incident Report for QuickBooks
Resolved
The issue that was limiting some users from being able to verify their QuickBooks Online access via a Gmail account has been resolved.

We apologize for the inconvenience and thank you for your patience and continued support.
Posted Jun 30, 2020 - 18:48 PDT
Investigating
QuickBooks Online customers are currently experiencing issues when attempting to sign in and pass multi-factor authentication. The verification email option will not be available for Gmail accounts until the issue is resolved.

Our engineers are aware of the problem and working to have the issue resolved as quickly as possible.
Posted Jun 30, 2020 - 13:17 PDT
This incident affected: QuickBooks Online (United States).