QBO Login Issue - Monitoring phase

Incident Report for QuickBooks

Resolved

An earlier issue with QBO prevented some users from logging into their accounts. Our teams have resolved the issue, and users should now be able to login.
Thank you for your patience as we worked to resolve this issue.
Posted May 07, 2025 - 15:58 PDT

Update

We are continuing to investigate this issue.
Posted May 07, 2025 - 14:26 PDT

Investigating

Some customers were unable to login in to their QuickBooks Online account. A fix has been implemented and we are monitoring the results. We’ll share any additional updates as soon as we learn more. We apologize for the inconvenience and hope to get everything up and running soon.
Posted May 07, 2025 - 14:25 PDT
This incident affected: QuickBooks Online (United States).