Some customers may not be able to access Payroll services
Incident Report for QuickBooks
Resolved
The earlier issue with Payroll services have been resolved.

Thank you for your patience as we worked to resolve this issue.
Posted Jul 19, 2024 - 13:02 PDT
Monitoring
Payroll services are currently stable and we are monitoring the results. We’ll share any additional updates as soon as we learn more. We apologize for the inconvenience.
Posted Jul 19, 2024 - 05:35 PDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 02:37 PDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 00:59 PDT
Investigating
We are investigating reports of connectivity issues which may cause interruption to accessing Payroll services during this time. We apologise for any inconvenience and will provide further update as soon as it becomes available.
Posted Jul 18, 2024 - 23:45 PDT
This incident affected: QuickBooks Online (United States, United Kingdom) and QuickBooks Desktop (United States).