Some customers are unable to login to QuickBooks and are seeing the error "Site cannot be reached"
Incident Report for QuickBooks
Resolved
We've confirmed yesterday that while all QuickBooks Online servers are fully functional, there were broader ISP outages occurring across Canada. However, all outstanding issue have now been resolved.

We apologize for the interruption in service and thank you for bearing with us.
Posted Nov 16, 2021 - 08:11 PST
Monitoring
The issues that were impacting various ISPs across Canada looks to be resolved. We are still monitoring the situation to ensure that all customers can access QuickBooks Online.
Posted Nov 16, 2021 - 06:36 PST
Update
We've confirmed that all QuickBooks Online servers are fully functional, however there are broader ISP outages occurring across Canada
Posted Nov 15, 2021 - 15:03 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2021 - 13:22 PST
Investigating
Some customers may be unable to access login to QuickBooks Online and are seeing the error "Site cannot be reached."
We’re aware of this issue and are working to fix it. We’ll share updates as soon as we learn more.
We apologize for the inconvenience and hope to get everything up and running soon!
Posted Nov 15, 2021 - 13:20 PST
This incident affected: QuickBooks Online (Canada) and QuickBooks Self-Employed (Canada).