Our phone and chat support are currently experiencing an unexpected service disruption, impacting support to AU and ROW customers.

Incident Report for QuickBooks

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 23:04 PDT

Monitoring

Please be advised that our phone and chat support is temporarily unavailable.
Our team is working to restore full service urgently and we apologize for any inconvenience.
Posted Oct 09, 2025 - 20:46 PDT