QuickBooks Desktop Payroll updates returning Internet connection error

Incident Report for QuickBooks

Resolved

Our teams have identified and resolved the underlying problem. All services are now restored and functioning normally.

We appreciate your understanding and patience.
Posted Jun 15, 2026 - 11:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results. We’ll share any additional updates as soon as we learn more. We apologize for the inconvenience and hope to get everything up and running soon.
Posted Jun 15, 2026 - 09:47 PDT

Update

We're currently investigating an issue that may be affecting some of our services. We appreciate your patience as we work to identify and resolve the problem. We'll provide another update as soon as we have more information.
Posted Jun 15, 2026 - 09:45 PDT

Investigating

Engineers are aware of the issue and it is in the process of being prioritized/investigated. Although this is being actively looked at, we do not have an ETA for resolution at this time.
Posted Jun 15, 2026 - 07:54 PDT
This incident affected: QuickBooks Desktop (United States).