Citibank customers are unable to connect accounts or update Bank Feeds in QuickBooks
Incident Report for QuickBooks
Resolved
An earlier issue with connecting and refreshing Citibank accounts in QuickBooks has been resolved. Please try again to connect your Citi accounts or refresh banking feeds. Thank you for your patience as we worked with Citibank on resolution.
Posted Apr 12, 2019 - 15:23 PDT
Investigating
Some Citibank customers are currently unable to connect new accounts or refresh Bank Feeds. This is impacting QuickBooks Online and QuickBooks Self-Employed. We are working with Citi on fixing the problem. We apologize for any inconvenience this may cause.
Posted Apr 12, 2019 - 08:53 PDT