Some customers may be unable to access the einvoice payment page
Incident Report for QuickBooks
Resolved
Issue has now been resolved, payment page is now available. Thank you for your patience.
Posted Sep 12, 2019 - 13:15 PDT
Investigating
Some customers are currently unable to access the einvoice payment page. A "503 Service Unavailable" error may be displayed or the page may be blank. We’re aware of this issue and are working to fix it. We’ll share updates as soon as we learn more. We apologize for the inconvenience and hope to get everything up and running soon!
Posted Sep 12, 2019 - 12:48 PDT