Some customers are unable to edit their employees and/or Contractors
Incident Report for QuickBooks
Resolved
This incident has been resolved. All customers are now able to edit contractors and employees with no issue.
Posted Feb 12, 2019 - 15:27 PST
Identified
The issue has been identified and we are working on implementing a fix at this time.
Posted Feb 12, 2019 - 15:07 PST
Investigating
Some customers are seeing an unresponsive page when attempting to edit their employees or contractors. We are aware of this issue and are working to fix it.
Posted Feb 12, 2019 - 12:55 PST